Superuser  for iBall Andi 4.5P Glitter


V3.1.3 Stable Version

4.4 1.4MB 50,000k+
Virus free No ads
  • C Launcher
  • Superuser  for iBall Andi 4.5P Glitter
  • Superuser  for iBall Andi 4.5P Glitter
  • Superuser  for iBall Andi 4.5P Glitter


Grant and manage Superuser rights for your phone

iBall Andi 4.5P Glitter smartphone was launched in April 2014. The phone comes with a 4.50-inch touchscreen display with a resolution of 480 pixels by 854 pixels. iBall Andi 4.5P Glitter price in India starts from Rs. 3,999.

The iBall Andi 4.5P Glitter is powered by 1.3GHz quad-core it comes with 512MB of RAM. The phone packs 4GB of internal storage that can be expanded up to 32GB via a microSD card. As far as the cameras are concerned, the iBall Andi 4.5P Glitter packs a 8-megapixel primary camera on the rear

The iBall Andi 4.5P Glitter runs Android 4.2 and is powered by a 1450mAh removable battery.

The iBall Andi 4.5P Glitter is a dual SIM (GSM and GSM) smartphone that accepts Regular and Regular. Connectivity options include Wi-Fi, GPS, Bluetooth, FM and 3G. Sensors on the phone include Proximity sensor and Accelerometer.


How to download Superuser form iBall Andi 4.5P Glitter?

  1. Check the Android version to verify compatibility of Superuser with iBall Andi 4.5P Glitter.
    Find Android version: go to "Settings" - "About the phone" - "Android version". Make sure Superuser is compatible with iBall Andi 4.5P Glitter.
  2. Click the download button to download Superuser in iBall Andi 4.5P Glitter.
  3. Once the download and installation are complete, find Superuser in your home screen and tap the icon to open it.

App Reviews for iBall Andi 4.5P Glitter

  • Chris Gevaert
    Will we ever see updates? The app is great as is but just wondering... No response means no more development? In that case I wish I never purchased this app Still its worth the investment
  • A Google User
    Great but ...
    This was working fine for me just yesterday, when I finally rooted (XTC Clip, CWM, and nd Super User). HTC ChaCha/Status. At some point following the most recent update SU started to act slow, or crash ... Installed it from CWM Recovery and everything was fine afterwords. Make it that easy to run as an apk from normal OS mode and will give 5 stars.
  • A Google User
    Worked on first Razr, fails on second..
    I was able to update and update the su binary on my Razr with no issues. Updated on my wifes Razr and it fails to regain root while updating su binary. Please help... Update: uninstalled, reinstalled update, rebooted, and everything worked!
  • Ovo borus
    Rooted ZTE Merit - Alienware Rom
    Not sure if it is safe to update. Last update killed my root and I had to flash a backup to get SU access. Also SU would not update and when I hotfixed it and it finally updated the new binary wasnt working and denied root access to SU. Again had to flash... so is it safe this time??
  • A Google User
    Great but need some help
    Love superuser ever since I rooted my shooter its been working better then ever. I can someone please tell me though when I go to update from 2.3.1 to whatever the new binary is. Why does it get all the way through update just to tell me the test was a failure
  • A Google User
    EVO 4G CM7 V 7.2.0
    Yep, for me / my device it only works / installs when ADB (debug mode) is checked...unchecked and it force closes. Other than that, works great and feel it is still a 5 star app.
  • Aaron Calma
    Some issues after updating root binary
    Works perfectly before I got a notification to upgrade su binary. and when i did upgrade, superuser always force closes and doesn't give permission to root apps anymore or even a notification for newly installed root apps. Please help me resolve this issue or maybe an update to fix it. Thanks! *update* -tried tuning on usb debbuging and it worked again :)
  • A Google User
    Binary update
    Previously when I tried to update the binary it fails and my phone gets rebooted automatically. After updating my busybox pro to the latest version the update goes very smoothly. So those who encounter binary update problem please update your busybox to the latest version and then update the binary. That will solve the problem. Until now I ha ve never faced any problem. After update, all data of the previous version except the su binary is saved. So applications won't ask for root access. Thanks.
  • A Google User
    Latest update works just fine!
    If you are having issues, do a little homework before whining about the app. Mostly seeing "operator error" type of complaints about this update. If you can figure out how to root your phone in the first place, you can surely figure how to update this app.
  • A Google User
    I found the problem
    When installing it say, fail. You need the latest version of Busybox, I do that and everything work just fine. I my case I was flashing my CM7 with the 7.2.0 version, next I download the latest Busybox and the last thing, the Superuser update. :)
  • A Google User
    Just rooted a LG E720... I bought my phone unlocked and it was loaded with a bunh of junk apps from the original carrier! The phone has a decent Processor but was really slow... Using Gingerbreak and Superuser I pretty much got my phone to be just as quick as some top of the line phones! Also, I highly recommend SetCPU
  • A Google User
    Great, This Version Anyway
    Recently, I moved from an app drawer SU 3.1.3 to the system app SU 3.2 from the dedicated website. I guess when the change was made to flat files, or maybe the fix on requesting permission, the app went haywire for me. I still had root access, but it would consistantly ask me for access right, even with remember checked. Also, I believe it caused my WiFi tether to act up, which isnt good seeing as my only internet is my phone. In process of rolling back. Stock ICS EVO3D CDMA Unlocked BL S-On, hboot 1.58
  • Jeff Antonelli
    Still works...but...
    My new developer HTC Rezound came with this preinstalled but had issues checking for new binary right from the box. Would fail, then it will f/c. It dose work fine besides that, for # commands. Also keeps downgrading back to old version (pirate b&w logo) after reboot.
  • techno314
    It works but
    When i try to update the binary, it says downloading manifest... failed. So when i press try again it goes to the screen before then it force quits. I don't know what this means but i hope you can tell me if its me or your application.
  • Susi K.
    Works great!
    I love it! Simple and safe! Only one thing that seemed to have a problem: updating su binuary keeps failing on my lg optimus ms690 with android 2.2*update* check mark usb debug mode fixes this. Updated su, but didnt see any changes. Not that i really know what that means...